Friday, May 27, 2011

Chapter 15. Software and Patch Management

Chapter Syllabus

15.1 Software Packaging Structure

15.2 Listing Installed Software

15.3 Installing New Software

15.4 Removing Software

15.5 Verifying Installed Software

15.6 Managing Software Depots

15.7 HP-UX Patches

15.8 Installing and Removing Patches

15.9 SD-UX Commands

Software on HP-UX systems is managed using Hewlett-Packard's Software Distributor, commonly known as SD-UX. This is not only a set of commands and utilities, but a system that defines how software should be packaged, bundled, copied, installed, and removed. SD-UX is based on the IEEE software distribution standard. It provides many commands that are used to install, remove, list, and verify software. SD-UX is used for managing and distributing operating systems, applications, and HP-UX patches. In a network environment, SD-UX can be used to set up a central software server from which any system on the network can install software as needed.

The main functions of SD-UX are to:

install software

remove software

list installed software

verify installed software

copy and package software

configure software

SD-UX can be used in either graphical user interface (GUI) or in a text user interface (TUI). The commands can also be used without any interface by using command line arguments.

SD-UX is used to manipulate all types of software, including HP-UX patches. The patches are additional software components that are released by Hewlett-Packard from time to time. These are used to add new functionality to existing system and application software, fixing bugs, or adding support of new hardware.

In this chapter, you will learn how the software is packaged and what the components of a software package are. You will use commands to list installed software, install new software, and remove installed software. Sometimes you need to verify the integrity of the installed software. SD-UX provides commands to verify installed software. Software depots are placeholders for software. You will see how to manage software depots with the help of SD-UX. An introduction to patches will be presented. You will learn how you can obtain patches for your software or hardware and how to install these. At the end of the chapter, a summary of commands used with SD-UX will be presented.

15.1 Software Packaging Structure

Software in SD-UX is organized in a hierarchy of components or objects. These components are filesets, subproducts, products, and bundles. The place where these components are stored is called a software depot. This provides a logical way to manage software. These components are explained below.

Filesets

A fileset is a collection of files and some control scripts. It is the basic entity in the SD-UX software packaging hierarchy. One fileset can belong to only one product, but it can be included in a number of subproducts and bundles. Some examples of filesets are shown here.

Ignite-UX.BOOT-KERNEL A.1.45 Installation Boot Kernel

for S700/S800 clients

Ignite-UX.BOOT-SERVICES A.1.45 Network Boot Services for

System Installations

Ignite-UX.FILE-SRV-10-20 A.1.45 File Archives Used By

Clients During HP-UX Install

Ignite-UX.IGNITE A.1.45 Graphical Ignite User

Interface for Installations

Keyshell.KEYS-ENG-A-MAN B.10.20

Keyshell.KEYSHELL-RUN B.10.20

LAN100-FRMAT-COM.LAN100-FORMAT B.10.20.02 100Mb LAN/

9000 formatter library

Subproducts

If a product contains several filesets, it is better to combine logically related filesets into subproducts. However, a fileset may be a member of many subproducts. Examples of subproducts are:

X11.Manuals X11 man pages

X11.MessagesByLang X11 Localized Messages

X11.MinimumRuntime X11 minimum runtime subproduct

X11.Runtime X11 full runtime subproduct

Products

A product is a superset of filesets and/or subproducts. By default, the SD-UX commands deal with products. An application, for example, is one product. A product may have many versions. Some of the products are:

UUCP B.10.20 Unix to Unix Copy

Upgrade B.10.20 Upgrade

X11 B.10.20 HP-UX X Window Software

Xserver B.10.20 HP-UX X Server

Y2KDocs B.10.20.B0315 Y2K Bundle Content file

Bundles

Bundles are usually packaged by HP-UX for the distribution of software. The bundles contain filesets that may belong to different products. A product may not necessarily be in one bundle, as bundles can have parts of different products. Operations related to software manipulation can be performed on bundles as one entity. Some examples of bundles are shown here.

J2760AA_APZ B.10.20.02 HP-PB 100Base-T/9000

OnlineDiag B.10.20.06 HPUX 10.0 Support Tools Bundle

Y2K-1020S800 B.10.20.B0315 Core OS Year 2000 Patch Bundle

Software Depots

Software depots are places where filesets, products, and bundles are stored. A software depot may a directory on your disk, a CD-ROM, or a tape (DDS, DAT) used for distributing software. By default, the software depot directory is /var/spool/sw, but you can use any directory as a software depot. Using SD-UX commands, software components can be added to or removed from a depot. For example, you can add new software patches to your local depot.

It is possible to create many software depots on one server for different applications. Software depots can be maintained on a central server in a network. Any machine on the network can install software from that central server. This is efficient, as installation of software from the network takes less time compared with installation from a CD-ROM or tape drive.

15.2 Listing Installed Software

The installed software can be listed using the swlist command. By default, the swlist command lists all software bundles and all products that are not part of a bundle. A typical output of the command is:

# Initializing...

# Contacting target "myhp"...

#

# Target: myhp:/

#

#

# Bundle(s):

#

82491BA B.11.00 MirrorDisk/UX

B3693AA C.02.15.000 HP GlancePlus/UX for s800

11.00

B3701AA B.11.00.41 HP GlancePlus/UX Pak for

s800 11.00

B3835BA B.11.02 HP Process Resource

Manager

B3901BA B.11.01.06 HP C/ANSI C Developer's

Bundle for HP-UX 11.00 (S800)

B3919EA_AGL B.11.00 HP-UX 8-User License

B3929BA B.11.00 HP OnLineJFS (Advanced

VxFS)

B4967AA C.02.15.000 HP MeasureWare Server

Agent for s800 11.00

B5725AA B.1.51 HP-UX Installation

Utilities (Ignite-UX)

HPUXEng64RT B.11.00 English HP-UX 64-bit

Runtime Environment

Ignite-UX-11-00 B.1.51 HP-UX Installation

Utilities for Installing 11.00 Systems

J1642AA B.11.00.03 HP PCI/HSC Gigabit

Ethernet Driver

XSWGR1100 B.11.00.43 HP-UX Extension Pack,

December 1998

#

# Product(s) not contained in a Bundle:

#

PHCO_14084 1.0 csh(1) patch

PHCO_14257 1.0 pwgrd consumes CPU when

time set backwards

PHCO_14786 1.0 Locales Y2K patch

PHCO_14859 1.0 cumulative 10.20 libc

compatibility support

PHCO_14887 1.0 cumulative SAM/ObAM patch

PHCO_15217 1.0 Cumulative SCCS(1)

including Year 2000 Fix

You can use the options shown in Table 15-1 with this command to get a list of the installed software.

Table 15-1. Options Used with swlist Command

Option

Meaning

-l bundle

List bundles only

-l products

List products

-l fileset

List filesets

-d @ /var/spool/sw

List software in depot /var/spool/sw

-l file X11

List all files that are part of the X11 product

-d @ hp1:/mydepot

List software in depot named mydepot on host hp1

Partial output of the swlist -l product command is as follows.

# Initializing...

# Contacting target "myhp"...

Package-Manager A.11.04 HP Package-Manager

PatchText Patch Documentation Files

PrinterMgmt B.11.00 PrinterMgmt

Proc-Resrc-Mgr B.11.02 HP Process Resource Manager

ProgSupport B.11.00 ProgSupport

SCSI-Passthru B.11.00 HP SCSI-Passthru Driver

SOE B.11.00 SOE

SUPPORT-TOOLS B.11.00 HP SUPPORT TOOLS

SW-DIST B.11.00 HP-UX Software Distributor

SecurityMon B.11.00 SecurityMon

ServiceGuard A.11.04 Service Guard

SourceControl B.11.00 SourceControl

Spelling B.11.00 Spelling

Streams B.11.00 HP-UX_10.0_Streams_Product

Streams-TIO B.11.00 HP-UX_10.0_Streams-TIO_Product

SystemAdmin B.11.00 HP-UX System Administration Tools

SystemComm B.11.00 System Communication utilities -

ct,cu,ptydaemon,vt,kermit

TechPrintServ B.11.00 HP-UX Technical Image Printing

Service

TerminalMngr B.11.00 TerminalMngr

TextEditors B.11.00 TextEditors

TextFormatters B.11.00 TextFormatters

UUCP B.11.00 Unix to Unix CoPy

Upgrade B.11.00 Upgrade

UserLicense B.11.00 HP-UX User License

WDB B.11.01.06 HP Wildebeest (HP WDB) Debugger

X11 B.11.00 HP-UX X Window Software

X11MotifDevKit B.11.00.01 HP-UX Developer's Toolkit - X11,

Motif, and Imake

Xserver B.11.00 HP-UX X Server

The swlist command can also be used to list software attributes such as size, revision, and vendor information.

15.3 Installing New Software

The swinstall command is used for software installation. Depending on the type of terminal you are using, the command starts in either text or graphic interface. If you are using a text-based terminal, you will see a message on your screen as shown in Figure 15-1. It is similar to the message screen you have seen while using SAM in Chapter 12.

Figure 15-1. Startup message of the swinstall command.

After this message, the TUI appears as shown in Figure 15-2.

Figure 15-2. The subwindow of the swinstall command.

First of all, a subwindow appears that shows some basic information. The Source Depot Type is Local CD-ROM, showing that software is going to be installed from a CD-ROM device. Source Host Name shows the name of the host that is being used as the source of the software depot. If you are on a network, you can change this source. Source Depot Path shows the path of the directory where the software depot resides. In this case, it is the directory where the CD-ROM is mounted. By default, the CD-ROM mount directory is /SD_CDROM, where the swinstall command looks for a software depot. With HP-UX version 10.20 and earlier, the system administrator needs to manually create a mount point and then manually mount the CD-ROM before using the swinstall command. With HP-UX 11.00 and later, SD-UX will automatically mount the CD-ROM via the swinstall command.

You can use the key to change any of these options. After pressing the button, the subwindow disappears and you see a window like the one shown in Figure 15-3, which lists the software packages present on the CD-ROM.

Figure 15-3. The software list on the CD-ROM.

Only the software listed is compatible with your system.

If you are using GUI, Figure 15-2 will look like Figure 15-4, and Figure 15-3 will be replaced by Figure 15-5. From a functionality standpoint, these are the same windows.

Figure 15-4. The subwindow of the swinstall command as viewed in GUI.

Figure 15-5. The software list on the CD-ROM as viewed in GUI.

If you want to install from a particular software depot, you can also mention the software source at the command line with the help of the -s switch. For example, to install software from a tape drive, use this command.

swinstall -s /dev/rmt/0m

To install software from a CD-ROM, with HP-UX 10.20 and earlier, mount the CD-ROM on /SD_CDROM with the help of the mount command and then use the following command. (For HP-UX 11.00, you don't need to use the mount command.)

swinstall -s /SD_CDROM

Phases of Software Installation

The software installation process is completed in only a few steps. In the first step, you initiate the swinstall command and select the software source depot. Once you get the list of software in that depot, you mark the software you want to install. To mark the software, first you need to highlight the software using the and spacebar keys. After highlighting, you can go to the Actions menu and select Mark for Install. If you just want to upgrade the existing software, you can go to the Actions menu and select the option Match What Target Has, and the selection will be made for you automatically.

Once all of the software is marked, go to the Actions menu and select the Install (Analysis)... option. When you select this option, the second phase of software installation starts the analysis phase. During this phase, all software dependencies and disk space requirements are checked. If the analysis phase succeeds, you will see a dialog box where you can see the results of the analysis. In case of any error, you can modify your software selection. If there are no errors, you can go to the actual installation phase where files are copied to the disk.

During the installation phase, all files from the selected software are copied to the disk. If a fileset is already installed, it is not reinstalled. However, to forcibly reinstall already installed software, you can go to the Options menu and select Change Options to force the reinstallation of already-installed files.

The last part of the software installation is the configuration and cleanup, where configuration scripts are run and temporary files are deleted. Temporary files are created during the installation process.

Install/Update Log File

All activities of the swinstall command are logged in the /var/adm/sw/swinstall.log file. A sample of entries in this log file is shown here.

======= 06/23/99 12:25:57 EDT BEGIN swinstall SESSION (interactive)

NOTE: The interactive UI was invoked, since no software was

specified.

Session started for user "root@myhp".

agent_auto_exit false

agent_timeout_minutes 10000

allow_downdate false

allow_incompatible false

allow_multiple_versions false

autoreboot false

autorecover_product false

autoremove_job false

autoselect_dependencies true

autoselect_reference_bundles true

compress_files false

control_lang C

create_target_path true

defer_configure false

enforce_dependencies true

enforce_dsa true

enforce_kernbld_failure true

enforce_scripts true

follow_controller false

job_polling_interval 30

log_msgid 0

logdetail false

logdetail false

loglevel 1

match_target false

mount_all_filesystems true

polling_interval 2

register_new_root true

reinstall false

reinstall_files true

reinstall_files_use_cksum true

retry_rpc 1

rpc_binding_info ncacn_ip_tcp:[2121] ncadg_ip_udp:[2121]

rpc_timeout 5

select_local true

software_view all_bundles

source_cdrom /SD_CDROM

source_type directory

source_directory hp1:/var/spool/sw

use_alternate_source false

verbose 1

write_remote_files false

* Source: myhp:/var/spool/sw

* Targets: myhp:/

* Software selections:

* Software selections:

PHCO_16964.PHCO_16964,r=B.10.00.00.AA,a=HP-HX_B.10.20_700/800,v=HP

PHCO_17075.PHCO_17075,r=B.10.00.00.AA,a=HP-UX_B.10.20_700/800,v=HP

PHCO_17240.PHCO_17240,r=B.10.00.00.AA,a=HP-UX_B.10.01_700/800,v=HP

PHCO_17552.PHCO_17552,r=B.10.00.00.AA,a=HP-UX_B.10.20_700/800,v=HP

PHCO_17630.PHCO_17630,r=B.10.00.00.AA,a=HP-UX_B.10.20_700/800,v=HP

PHNE_16692.PHNE_16692,r=B.10.00.00.AA,a=HP-UX_B.10.20_700/800,v=HP

PatchText.Y2K-1020S800,r=B.10.20.B0315,a=HP-UX_B.10.20_800,v=HP

Y2KDocs.Y2K-1020S800,r=B.10.20.B0315,a=HP-UX_B.10.20_800,v=HP

* A "+" indicates an automatic selection due to dependency or the

automatic selection of a reference bundle.

* Beginning Analysis

* The analysis phase succeeded for "myhp:/".

* Ending Analysis

* Beginning Task Execution

* Proceeding with Task Execution on the following targets:

* myhp:/

You can use this log file to view any complications occurring during the software installation process.

This log file contains some labels, which are explained next.

========

Indicates start or end of a task.

ERROR

Indicates a serious problem so that installation is not

======== Indicates start or end of a task.

possible.

WARNING

Shows that although the installation is performed, there may be a problem. Read the warning message to see what action you need to take for this problem.

NOTE

Any information is placed under this label. It may or may not require action. Most of the time you may ignore these messages.

Installing Protected Software Using Codewords

If you receive protected software from HP, you will also receive your customer ID and codeword. A codeword is generated using the part number of the medium on which the software is shipped, your customer ID, and the product ID. Codewords are confidential, and it is your responsibility to protect them.

When you start software installation from a CD-ROM that contains protected software, the swinstall command will show you a message that the CD-ROM contains protected software. In that case, you need to go to the Actions menu and select Add New Codeword. You will see a window like the one shown in Figure 15-6, where you enter your customer ID and codeword.

Figure 15-6. The window to enter customer ID and codeword.

You need to enter a codeword only once on your machine. It is then stored in the /var/adm/sw/.codewords file for future use.

Usually one codeword is used for one CD-ROM. Every time you purchase new software, you will receive a new codeword with it.

SD-UX Daemon and Agent

The software installation process is controlled by the daemon swagentd. If this daemon is not running, you can't start the software installation process. When you give the swinstall command, it connects to the swagentd daemon. The daemon starts the software agent named swagent whenever required. If the software depot is located on another machine on the network, the swagentd daemon connects to the daemon running on that host and initiates communication between the two hosts.

The SD-UX agent swagent is responsible for software management tasks. It is started by the swagentd daemon and terminates after the task is completed.

The SD-UX daemon is started at runlevel 2. So if you are in single-user mode, you can't install software. However, you can start the daemon manually in single-user mode using the following command.

/sbin/init.d/swagentd start

It can be stopped by the command:

/sbin/init.d/swagentd stop

Installed Product Database

HP-UX maintains a database of all installed software, the installed product database (IPD). During the analysis phase, the swinstall command uses this database to check the software already installed. The swlist command queries this database to list the installed software. Similarly, when the software is removed using the swremove command, this database is updated to reflect the removed software.

The SD-UX commands are responsible to maintain this database, which is stored in the /var/adm/sw/products directory structure.

15.4 Removing Software

The swremove command is used to remove software from the HP-UX system. It has a similar interface to the swinstall command. When you start the command, it will list in a window all installed software. You can mark the software that you want to remove from the system, after which you will go to the Actions menu and select Remove (Analysis) from it.

Once the software removal starts, the SD-UX checks the software dependencies and removes all files in the selected software that are not used by any other product or bundle. It then updates the IPD by removing software from it.

It is important to note that software is not removed only by deleting the directory in which the software was installed. In fact, manually deleting directories may cause problems because the software entries still exist in the IPD. Although you have deleted the files, your system thinks that they are still there. This may affect any other software installation or removal process when SD-UX checks software dependencies.

The software removal process is logged in the /var/adm/sw/swremove.log file. It is similar to the log file used for the swinstall command and contains information showing whether the software removal process was successful.

Finding and Removing Unused Filesets

The freedisk command is used to list and remove software that has not been used for a long time. Filesets that have not been used since installation, but which have dependencies with other filesets that are in use, are treated as being in-use. After analyzing the filesets, the command activates the swremove command to remove packages interactively. At this point, you can select packages that can be removed from the system.

15.5 Verifying Installed Software

The swverify command is used to verify software installed on a system or in a depot. When used to verify installed software, it checks file existence and integrity and file dependencies in a software package. It also executes any scripts supplied with the software to verify the software's integrity. The command can be used to verify software on multiple hosts. It also checks file attributes and reports missing files. When used with the -d option, it operates on a depot instead of on installed software. It returns an exit code equal to zero if all software verification is successful. The log of the command is recorded in /var/adm/sw/swverify.log, which can be checked for any error messages. For example, to verify Laser ROM on a local host, you can use this command.

swverify LROM

15.6 Managing Software Depots

Managing a software depot is an important task for routine system administration. You need to create your own software depot for larger networks to avoid installing the installation media on every machine.

A depot can be created in any directory on disk. The default software depot location is /var/spool/sw. After selecting a directory for the software depot, software components can be added or removed from the depot.

A tape depot can be created using the swpackage command. Only one command can access a tape depot at a time.

Adding Packages to a Depot

A package can be added to a depot using the swcopy command. This command copies into a depot the software that can be installed using the swinstall command at a later stage. The following command copies all products from a tape drive to the default software depot.

swcopy -s /dev/rmt/0m @ /var/spool/sw

Removing Packages from a Depot

Software can be removed from a depot using the swremove command. The following command removes all software from the default depot /var/spool/sw.

swremove -d * @ /var/spool/sw

Listing Packages in a Depot

Software in a depot can be listed using the swlist command. The following command list contents of the local tape, /dev/rmt/0m.

swlist -d @ /dev/rmt/0m

Study Break

Software Management

You have now studied most of the software management concepts and SD-UX commands. Log into your system and use the swlist command to list the software already installed on your system. Put the HP-UX additional software CD-ROM in the drive and mount it on directory /SD_CDROM. If your CD drive device is /dev/dsk/c2t5d0, the mount command will be:

mount /dev/dsk/c2t5d0 /SD_CDROM

On HP-UX version 10.20 and earlier, the system administrator needs to manually create a mount point and then manually mount the CD-ROM before using the swinstall command. On HP-UX 11.00 and later, SD-UX will automatically mount the CD-ROM via the swinstall command. The mount point will be /SD_CDROM.

Now use the swinstall command to see the software

components on the CD-ROM. Mark one of the products for installation and install it using options in the Actions menu. After installation is complete, use the swlist command again to make sure that the software is installed. Now use the swremove command to remove this software.

15.7 HP-UX Patches

HP-UX patches are software components that are released by Hewlett-Packard. These are used for one of the following purposes.

to add new functionality to the HP-UX operating system or products

to add support for new hardware; for example, support may be added for new types of adapters

to fix bugs in the operating system and applications

Patch management is an ongoing system administration task in HP-UX, as many patches are released from time to time.

Patch Sources

Patches can be obtained using your Web browser through WWW or FTP. The WWW site address is:

http://itresourcecenter.hp.com/

The FTP site address is:

ftp://us-ffs.external.hp.com/hp-ux_patches

You can also order a patch CD-ROM from Hewlett-Packard to obtain a collection of all patches.

CUSTOM PATCH MANAGER

This tool is available on the Hewlett-Packard Web site. It can be used to take inventory of existing software installed on your system and suggest needed patches. To use the custom patch manager, your system needs to be connected

to the Internet and you must have a Personalized System Support Agreement with Hewlett-Packard.

Types of Patches

All patch names start with PH. The next two characters show the type of patch. Following that, there is an underscore character and a four- or five-digit patch number. At the end of the patch name, there may be some other words to show the specific use of the patch. Depending on the characters in the type field, there are four types of patches as listed here.

Command patches. The type field for these is CO.

Kernel patches. The type field for these is KL.

Network patches. The type field for these is NE.

Subsystem patches. The type field for these is SS. These patches include all other types of patches.

Some example patch names are:

PHSS_16473

PHSS_14158

PHCO_15623

PHKL_16189

Usually you need to reboot the system after installing a kernel patch.

Listing Installed Patches

The procedure for listing patches is different for HP-UX versions. If you are using HP-UX 10.x, you can use following command.

swlist -l product PH*

On HP-UX 11.00, use:

swlist -l patch '*.*,c=patch'

or

swlist -l patch

15.8 Installing and Removing Patches

The process of patch management is not very different from general software management. The same SD-UX utilities are used for installing, removing, and listing patches as are used for general software.

Obtaining Patches

HP-UX patches are distributed as shar files. When you download a patch from the Hewlett-Packard FTP or Web site, use the sh command to unshar it. For example, to download the patch, PHCO_15220, you can use the following FTP process from the command line.

# ftp us-ffs.external.hp.com

Connected to hpcc933.external.hp.com.

220-

220-Welcome to the HP Electronic Support Center ftp server

220-------------------------------------------------------

220-

220-You are user 53, and there is a limit of 200 simultaneous accesses.

220-

220-Log in as user "anonymous" (using your e-mail address as your

password)

220-to retrieve available patches for HP-UX, MPE/iX, and other

platforms.

220-

220-If you are a user of other HP ESC services, log in with your

220-HP ESC User ID and password to deposit or retrieve your files.

220-

220-If you have questions, send email to:

220-

220- support_feedback@us-ffs.external.hp.com

220-

220 hpcc933 FTP server (Version wu-2.4, HP ASL, w/CNS fixes (277) Wed

Jun 24 18:

02:04 PDT 1998) ready.

Name (us-ffs.external.hp.com:boota): anonymous

331 Guest login ok, send your complete e-mail address as password.

Password:

230 Guest login ok, access restrictions apply.

Remote system type is UNIX.

Using binary mode to transfer files.

ftp> cd hp-ux_patches

250 CWD command successful.

ftp> cd s700_800

250 CWD command successful.

ftp> cd 11.X

250 CWD command successful.

ftp> get PHCO_15220

200 PORT command successful.

150 Opening BINARY mode data connection for PHCO_15220 (46784 bytes).

226 Transfer complete.

46784 bytes received in 1.04 seconds (44.02 Kbytes/s)

ftp> quit

221 Goodbye.

#

After downloading, use the following command to unshar the patch.

$ sh PHCO_15220

x - PHCO_15220.text

x - PHCO_15220.depot [compressed]

$

As you can see from the output of this command, two files are extracted from the package file. These files are always Patch_Name.text and Patch_Name.depot. The .text file is the patch description file and the .depot file is the actual patch in SD-UX depot format. The .text file contains the following information.

Patch name

Patch description

Creation date: shows the date the patch was created

Post date: shows the date when the patch was made public for general use

Hardware platforms—OS releases

Products

Filesets

Automatic reboot: shows whether the system will be rebooted after the installation of patch

Status: shows whether it is a general release or a special release

Critical: shows if the patch fixes a critical problem. A critical problem is one that causes system failure, crash, hang, panic, application failure, data loss, or corruption

Category tags

Path name: shows the file path on the FTP site

Symptoms

Defect description

SR: service request number, which is assigned to a formal request about the problem from a customer

Patch files

what(1) output: shows output of the what command for each file

cksum(1) output: used to detect any errors in the file

Patch conflicts

Patch dependencies

Hardware dependencies

Other dependencies

Supersedes

Equivalent patches

Installation instructions

Before installing a patch, you must read this information to find out its exact purpose.

Creating a Patch Depot

After you have unshared a patch, you can install it directly from the .depot file or you can add the .depot file to a patch depot on your system. I prefer the second option. To add the patch to the /var/spool/sw depot, use this command.

swcopy -s PHCO_15220.depot PHCO_15220 @ /var/spool/sw

Installing Patches

Patches can be installed with the help of the swinstall command. If you are using individual patches with the above-mentioned procedure, you can use the following command to get a list of software and patches from your default depot.

swinstall -s /var/spool/sw

When you use this command and the patches are present in this depot, you will see a list of all patches in the swinstall window. After making a selection in the usual way, you can install the desired patches.

If you have the patch CD-ROM from Hewlett-Packard and are not sure which patches to install, adopt the following process.

Insert the CD-ROM in the drive.

For HP-UX 10.20 and earlier, mount the CD-ROM on the /SD_CDROM directory using the mount command. Remember that, with HP-UX 11.00 and later, the CD-ROM is automatically mounted by swinstall.

Start swinstall.

Go to the Actions menu and select Match what target has on HP-UX 10.x or Manage patch selection on HP-UX 11.00.

Go to the Actions menu and select Install (analyze). . . to start the installation.

Removing Patches

Package removal is similar to general software removal. It is done with the help of the swremove command.

15.9 SD-UX Commands

Common SD-UX commands are presented in Table 15-2.

Table 15-2. Common SD-UX Commands

Command

Description

Table 15-2. Common SD-UX Commands

Command Description

swinstall

Install software

swremove

Remove installed software; also remove software from a depot

swlist

List installed software or software in a depot

swcopy

Copy software components to a software depot

swpackage

Package software in a depot

swreg

Make a software depot visible to other systems on the network

swverify

Verify integrity of installed software

swagentd

SD-UX daemon

swagent

SD-UX agent

swacl

Control access to software

swconfig

Configure installed software

Chapter Summary

You have used HP Software Distributor (SD-UX) in this chapter. You began with learning the structure of HP software packages. Filesets are combination of files. Subproducts are used to logically combine filesets of the same type. Products contain subproducts and filesets. Packages are used to distribute software and can contain full or partial products. The software is stored in software depots. A software depot may be a CD-ROM, a tape, or a directory on a server.

Software is installed with the help of the swinstall command, which can be started in text or graphical interfaces. For listing installed software or the contents of a software depot, you use the swlist command. The swremove command is used for removing software from a software depot or from the system. The swverify command checks the integrity of the installed software. To manage a software depot, you can use the swcopy, swremove, swlist, and swpackage

commands. The installed product database (IPD) is used to keep a record of installed or removed software. If new software is installed, it is added to this database. If you remove software using the swremove command, it is removed from the database. To use SD-UX, you need to run the SD-UX daemon named swagentd. This daemon invokes the SD-UX agent, swagent, whenever required. The freedisk command can be used to list and remove any unused software from the system.

Hewlett-Packard releases software updates from time to time. These updates are called patches. Patches are used to add new functionality, remove bugs, or add support for new hardware. The patches can be downloaded from the Hewlett-Packard Web site or the FTP site. Patches are managed in a way similar to general software management.

Test Your Knowledge

1:

What is not true about a fileset?

A. A fileset is a collection of files.

B. One fileset can belong to only one product.

C. One fileset can belong to many products.

D. Filesets may have dependencies with one another.

2:

What is the default location of software on your disk?

A. /var/spool/sw

B. /etc/default/sw

C. /var/sd-ux/sw

D. none of the above

3:

When the swlist command is used without any arguments, it lists:

A. all bundles

B. all products

C. all bundles and all products

D. all bundles and only those products that are not included in a bundle

4:

When using the swinstall command in the text menu, you can activate the menus using the:

A. key

B. key

C. function key

D. Spacebar

5:

In which runlevel is the SD-UX software daemon started?

A. 1

B. 2

C. 3

D. 4

6:

What is the use of the freedisk command?

A. to check the amount of free space on a disk

B. to check for unused software on a disk

C. to check a disk that is completely free

D. to wipe out all software from a disk to make it free

7:

Which SD-UX command is used to install software?

A. swinstall

B. swcopy

C. swconfig

D. all of the above

8:

For what purpose are patches not used?

A. add new functionality

B. fix bugs in applications

C. fix bugs in hardware

D. add support for new hardware

9:

Every patch is a shar file when you download it from the Hewlett-Packard

Internet site. How many files are created when you unshar it?

A. 2

B. 3

C. 7

D. 10

51 comments:


  1. Excellent post and wonderful blog, I really like this type of interesting articles keep it u

    123hpremoteassistance Officejet 6830 Printer Setup

    ReplyDelete
    Replies
    1. Hp-Ux: Chapter 15. Software And Patch Management >>>>> Download Now

      >>>>> Download Full

      Hp-Ux: Chapter 15. Software And Patch Management >>>>> Download LINK

      >>>>> Download Now

      Hp-Ux: Chapter 15. Software And Patch Management >>>>> Download Full

      >>>>> Download LINK Id

      Delete
  2. Really very interesting and very valuable information about the health and good HPUX Migration keep posting.
    HPUX Migration

    ReplyDelete
  3. Substantial articles 123.hp com/setup Thanks for sharing useful information

    ReplyDelete
  4. Friendly Thought https://123-hp-com-envy7158.com/ Thanks for sharing, Fruitful Thought https://123-hp-com-envy4520.com/ Thanks for sharing, Full of beans Tip https://123-hp-com-oj4655.com/ Thanks for sharing, Full of promise Topic https://123-hp-com-ojp8715.com/ Thanks for sharing, Gainful Typical https://123-hp-com-dj2655.com/ Thanks for sharing

    ReplyDelete
  5. very nice blogs!!! i have to learning for lot of information for this sites...Sharing for wonderful information.Thanks for sharing this valuable information to our vision. You have posted a trust worthy blog keep sharing.


    hp envy 5055 wireless setup

    ReplyDelete
  6. My cousin recommended this blog and she was totally right keep up the fantastic work!


    setup wireless hp printer officejet pro 6968

    ReplyDelete
  7. Do You Have What It Takes To Nd10x Review A Truly Innovative Product? https://www.reviewengin.com/nd10x-review/

    ReplyDelete
  8. I might currently know the things that you know. I encourage you to start your education with reference to Control X Keto Weight Loss. This may be for those of you with a Weight Loss that ends with a territory for a Weight Loss. That is too hot to handle. Here's a free and easy way to use Weight Loss. I am not blind to the faults of Weight Loss.

    https://www.nutramini.com/control-x-keto-reviews/

    https://www.nutramini.com/keto-go-fit/

    http://latestreviews.over-blog.com/drone-xtreme-reviews/

    http://nutragrow.over-blog.com/toxifort-thailand/

    https://nutramini.blogspot.com/2019/12/control-x-keto-reviews.html

    http://nutramini.over-blog.com/control-x-keto/

    ReplyDelete
  9. https://hpunix.blogspot.com/2011/05/chapter-15-software-and-patch.html?showComment=1547274030884#c578707816879837062

    ReplyDelete
  10. Thanks to admin because you're sharing with us Knowledge. Your Site is extremely helpful and informative site. I even have some site such as you and related your site. Who wants to urge more knowladge check it below many thanks


    hp printer offline
    123.hp.com
    123.hp.com/setup
    hp printer support

    ReplyDelete
  11. Nice post and please provide more information. Thanks for sharing.
    123.hp.com/oj3830

    ReplyDelete

  12. As usual, I don't add to the dilemma. Gadgets is graceful. Sure there

    are a ton of Gadgets but few common people seem to make the effort with Gadgets.


    AOL support number
    powervolt energy saver

    ReplyDelete

  13. How do

    dabblers snag reasonable Tech Products reviews? I've got bigger fish to fry. I was able to hang out with several celebrities recently. It was started by Gadgets

    experts. It is how to quit worrying about something. You need to get results.




    PowerPro Energy Saver
    Mosquitron
    Buzz B Gone

    ReplyDelete
  14. This post is really nice and informative. The explanation given is really comprehensive and informative..
    123.hp.com/oj7740 Printer Wireless Setup

    ReplyDelete
  15. This comment has been removed by the author.

    ReplyDelete
  16. This comment has been removed by the author.

    ReplyDelete
  17. Thanks for sharing the beautiful informationui ux design

    ReplyDelete
  18. How Does Internet Marketing Benefit Consumers
    These pages inform your viewers about your services, and may embrace pictures and different types of multimedia to maintain customers engaged. Typical article pages are usually 500 phrases lengthy, however you may also write “longform” content, and purpose for round 2,000 words. PPC, or pay-per-click on promoting, is an effective way to promote your organization on-line and reach customers who are actively looking for particular products and services.
    Also called on-line advertising, internet marketing is the process of selling a enterprise or brand and its products or services over the web utilizing instruments that help drive visitors, leads, and gross sales. Social media marketing is creating content material to advertise your brand and products on various social media platforms like Facebook, Instagram, LinkedIn, and Twitter. No one logs on to social media on the lookout for something to purchase, so suppose via what kinds of content material that's useful, informative, entertaining, and/or compelling. Your distinctive content material must be tailored to the specific platform you share it on that will help you enhance your submit’s attain.
    We provide a number of Internet marketing companies together with SEO, PPC, content material advertising, e-mail advertising, social media, CRO, and extra to assist our clients attain more prospects and earn more income on-line. This may even help your small business make the most out of your advertising spend because you won’t waste cash making an attempt to succeed in individuals who aren’t interested in your products or services. Influencer marketing plans from WebFX give you access to our giant listing of bloggers who can begin constructive conversations about your small business, products, and model online. https://www.reviewengin.com/6-tips-on-strategic-instagram-marketing/

    ReplyDelete
  19. Thanks for sharing this useful information. Need support for HP Printer, visit our website.

    123.hp.com | 123.hp.com/setup | hp officejet 5258 driver | hp envy 5070 driver | hp officejet 5255 driver .

    ReplyDelete
  20. Really awesome blog. Your blog is really useful for me. Thanks for sharing this informative blog.
    123 HP Envy 7640 Wireless Setup

    ReplyDelete
  21. Useful information. Thanks for sharing.
    Need Epson printer driver assistance? Feel free to reach our website!
    Epson printer driver | Epson connect printer setup utility 

    ReplyDelete
  22. This will help you budget your business more effectively, or reveal that it’s a dead end because you can’t compete with their prices. Design by ShubhamBaakreOf course, if your offline career is doing well, you have to ask yourself if switching online is really necessary. Maybe you like working directly with people, or maybe you prefer offline methods of attracting new business. Consider both your personal taste and the online demand for your services before making a decision to upend your offline business. Camera fanatics can make a lot of money in this industry. The video content tends to be between 15 and 30 seconds long, in resolutions of 1080p and higher – the market demand is greater for footage in formats such as 4K.
    A daily deals site, as the name suggests, is a site where consumers can find heavily discounted products and services, for one day only. You’ll have to source lots of brands and merchants to work with to make the site successful, which can be very time-consuming. However, most vendors are open to offering good discounts in exchange for the marketing opportunity, as the offers are only available for a day.
    This job requires attention to detail and expertise in the area to ensure that everything is ready to print. Starting a Podcast, which are under-utilized channels of communication for influencers right now. Ecommerce SEO optimization, and similar one-off packages. Start a business and design the life you want – all in one place.
    But, you still need to make sure that the platform you choose accepts credit card payments and that it has other features you need in your store. By answering these questions, you’ll be able to brainstorm a few creative yet relevant concepts that can ultimately help you choose a business, brand, and domain name. If you haven’t decided on your business name, you’ll want to start narrowing the options and thinking about your branding elements at this stage. Some business owners prefer a looser approach, so they only create a more casual outline for each goal that is often hard to track or quantify. From order processing to fulfillment, packaging, and the actual shipping carrier, you’ll want to consider all of these and find a reliable solution for each before you get started. Consumers love creativity and personality, so develop a flexible business model that can be changed according to your audience’s preferences and the results you’re getting. https://www.reviewengin.com/10-ecommerce-business-ideas-2022/

    ReplyDelete
  23. Hp-Ux: Chapter 15. Software And Patch Management >>>>> Download Now

    >>>>> Download Full

    Hp-Ux: Chapter 15. Software And Patch Management >>>>> Download LINK

    >>>>> Download Now

    Hp-Ux: Chapter 15. Software And Patch Management >>>>> Download Full

    >>>>> Download LINK z6

    ReplyDelete
  24. Though the safety of self-driving cars is a high concern of potential users, the know-how continues to advance and enhance with breakthroughs in AI. These automobiles use machine-learning algorithms to combine data from sensors and cameras to understand their environment and determine the best plan of action. Artificial basic intelligence (AGI), also identified as sturdy AI, is still a hypothetical concept as it involves a machine understanding and performing vastly totally different duties primarily based on its accrued experience.
    Machine learning is useful for putting vast troves of information – more and more captured by connected devices and the Internet of Things – into a digestible context for people. Machine learning is one of the most typical types of AI in growth for business purposes at present. Machine studying is primarily used to process large quantities of knowledge shortly. In reality, most of us interact with AI in some type or another on a daily basis. From the mundane to the breathtaking, artificial intelligence is already disrupting just about every business course of in every industry. As AI technologies proliferate, they are turning into imperative to take care of a competitive edge.
    Simplilearn's Artificial Intelligence fundamentals program is designed to help learners decode the mystery of synthetic intelligence and its enterprise applications. The course supplies an outline of AI concepts and workflows, machine studying and deep learning, and performance metrics. You’ll study the distinction between supervised, unsupervised and reinforcement learning, be exposed to make use of circumstances, and see how clustering and classification algorithms help identify AI enterprise purposes. https://www.reviewengin.com/artificial-intelligence/

    ReplyDelete